1//===----------------------------------------------------------------------===//
2//
3// Part of the LLVM Project, under the Apache License v2.0 with LLVM Exceptions.
4// See https://llvm.org/LICENSE.txt for license information.
5// SPDX-License-Identifier: Apache-2.0 WITH LLVM-exception
6//
7//===----------------------------------------------------------------------===//
8
9// <memory>
10
11// weak_ptr
12
13// template<class T> void swap(weak_ptr<T>& a, weak_ptr<T>& b)
14
15#include <memory>
16#include <cassert>
17
18#include "test_macros.h"
19
20struct A
21{
22 static int count;
23
24 A() {++count;}
25 A(const A&) {++count;}
26 ~A() {--count;}
27};
28
29int A::count = 0;
30
31int main(int, char**)
32{
33 {
34 A* ptr1 = new A;
35 A* ptr2 = new A;
36 std::shared_ptr<A> p1(ptr1);
37 std::weak_ptr<A> w1(p1);
38 {
39 std::shared_ptr<A> p2(ptr2);
40 std::weak_ptr<A> w2(p2);
41 swap(w1, w2);
42 assert(w1.use_count() == 1);
43 assert(w1.lock().get() == ptr2);
44 assert(w2.use_count() == 1);
45 assert(w2.lock().get() == ptr1);
46 assert(A::count == 2);
47 }
48 }
49 assert(A::count == 0);
50
51 return 0;
52}
53

source code of libcxx/test/std/utilities/memory/util.smartptr/util.smartptr.weak/util.smartptr.weak.spec/swap.pass.cpp